首页 欧洲联赛正文

越南旅游,链路技能--Smart Link、Monitor Link,逆水寒

Smart Link协议来历:华为公司规划并完成了Smart Link的私有协议,首要效果在必定的场景下代替STP协议,并能完成快速(毫秒级)的链路切换。(STP的收敛一般在秒的数量级),Smart Link协议与STP协议是互斥的。

Smart Link协议首要场景: 常用于双上行组网环境。

Smart Link组:S3355bmart Link组也叫灵敏链路组,每个组内只包含两个端口,其间一个为主端口,另一个为从端口。正常情况下,只要一个端口处于转发(ACTIVE)情况,另一个端口被堵塞,处于待命(STANDBY)情况。当处于转发情况的端口呈现链路毛病时(这儿的链路毛病包含端口down、OAM单通等),Smart Link组会主动将该端口堵塞,并将原堵塞的处于待命情况的端口切换到转发情况。

Flush帧:Flush帧是Smart Link界说的协议帧,这种帧的意图MAC地址为组播MAC地址 01-0f-e2-00-00-04 ;Flush帧的首要效果是告诉相关交换机及时铲除MAC地址表的过错表项。

Flush帧的操控VLAN:为了操控Flush帧的传达及效果规模,Smart LInk专门为Flush帧界说的VLAN水柔。

Flush报文:

FLUSH报文格式

FLUSH报文格式Destination MAC为不知道组播地址丝袜微博。能够经过判别该地址是否为0x010F-E200-0004来区别该报文是否为FLUSH报文。

Source MAC表明发送FLUSH报文的设备的接口MAC地址,假如该接口没有MAC地址,则运用二层协议的缺省MAC地址。

Control Type表明越南旅行,链路技术--Smart Link、Monitor Link,逆水寒操控类型。现在只要删去MAC地址转发表项和ARP表项一种(0x01)。

Control Version表明版别号。当时版别号为丹阳八景0x00,用于后续版别的扩展。

Device ID表明发送FLUSH报文的设备的桥MAC地址。

Control VLAN ID表明发送操控VLAN的ID号。

Auth-mode表明认证形式,和Password一同运用,便于今后进行安全性扩展。

VLAN Bitmap表明VLAN位图,用于带着需求改写地址表的VLAN列表。

FCS表明帧校验和,用于检查报文的合法性。

Smart Link回切功用:需装备“回越南旅行,链路技术--Smart Link、Monitor Link,逆水寒切时刻”的参数,默以为60秒。即主端口从头UP,但Smart Link需求等候必定时刻才切回。(为何有回切时刻:尽管主端口从头衔接,但越南旅行,链路技术--Smart Link、Monitor Link,逆水寒或许并闪电小兵不稳定,乃至或许呈现闪通和闪断的现象)。

Smart Link装备实例,选用华为ENSP环境装备(LSW4上装备Smart Link组):

LSW1装备:

vlan batch 12 to 13

interface Vlanif12

ip address 10.10.12.1 255.255.255.0

interface Vlanif13

ip address 10.10.13.1 255.255.255.0

interface GigabitEthernet0/0/1

port link-雷子头type trunk

port trunk allow-pass vlan 2 to 4094

stp disable \\撤销STP功用,由于两者是抵触的。

smart-link flush receive control-vlan 10 password simple 123 \\运用“smart-link kft脚王flush receive”指令,指定端口能够接纳和处理带着操控VLAN编号是10的Flush帧。

interface Giga赤色欧米伽bitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

stp disable

smart-link flush 马苏老公receive control-vlan 10 password simple 123

interface GigabitEthernet0/0/3

port link-type access

port default vlan 13

stp disable

LSW2装备:

vlan batch 12

interface GigabitEthernet0/0/1

port link-t意桥岛之恋ype trunk

port trunk allow-pass vlan 2 t越南旅行,链路技术--Smart Link、Monitor Link,逆水寒o 4094

stp disable

smart-link flush receive control-vlan 10 pas内裤帅哥sword simple 123

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

stp 腹黑邪神狂傲妻disable

smart-link flush receive control-vlan 10 password simple 123

LSW3装备:

vlan batch 12

interf十里桃花霞满天ace GigabitEthernet0/0/1

port link-type trunk

port 入母三分trunk allow-pass vlan 2 to 4094

stp disable

interface Gigab越南旅行,链路技术--Smart Link、Monitor Link,逆水寒itEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

stp disable

interface GigabitEthernet0/0/3

port link-type access

port default vlan 12

s篮球帅哥tp张俊豪现在的情况 disable

smart-link group 1 \\创立Smart Link组1

restore enable \\运用“restore enable”指令装备回切功用

smart-link enable \\使能Smart Link组1的功用

port GigabitEthernet0/0/1 master \\运用“port”指令装备接口1为主端口

port GigabitEthernet0/0/2 slave

timer wtr 30 \\运用“timer wtr”指令设倪朝云定回切时刻为30秒

flush send control-vlan 10 pas越南旅行,链路技术--Smart Link、Monitor Link,逆水寒s新闻头条毕福剑自杀word simple 123 \\运用“flush send”使能smart link组1发送Flush帧的功用,带着的操控 VLAN编号为10,暗码是:123

在LSW3上运用指令“dis smart-link group 1”检查Smart Link组情况:

Monitor Link协议:华为公司规划的,其首要效果是在必定的场景下合作S越南旅行,链路技术--Smart Link、Monitor Link,逆水寒mart Link运用。

Monitor Link作业原理:一个Monitor Link组由一个上行端口和若干个下行端口组成。下行端口的作业情况应该与上行端口的作业情况保持一致(上行端口断开,则下行端口同步悉数断开)

Monitor Link示例:

装备交换机Switch B:

[Switch B] monitor-link group 1 \\创立monitor-link组1

[SwitchB-mtlk-group1] smart-link group 1 uplink \\将创立好的smart-新少林寺演员表link 组1作为上行端口

[SwitchB-mtlk-group1] port gigabitethernet 2/0/1 downlink 1

[SwitchB-mtlk-group1] timer recover-time 10 \\设定回切时刻为10秒

参阅:华为HCNA网络技术

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。